re = /(?<=www.)[\w\.\/]+|(?<=http:\/\/)[\w\.\/]+/m
str = ' www.example.com/directory
http://example.com/directory'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end