$re = '/^[\w\s-_]{3,50}$/u';
$str = 'Морковь-123 ewrr4_5eewr';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);