$re = '/^(?!0[0-9.()-]$)/m';
$str = '87.6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);