$re = '/RX_IST2_AM\ \[PID:\d{1,6}\ NPID:\d{1,5}\ SID:\d{1,9}\] sbivvrwm060\.dev\.ib\.tor\.Test\.com:30000/';
$str = 'RX_IST2_AM [PID:942564 NPID:10991 SID:498702881] sbivvrwm060.dev.ib.tor.Test.com:30000
RX_IST2_AM [PID:1234 NPID:22222 SID:987654321] sbivvrwm060.dev.ib.tor.Test.com:30000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);