package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[a-z.]+@[a-z]+\.[a-z]+`)
var str = `Practice @Geeksforgeeksexpand_more
Algorithmsexpand_more
Data Structuresexpand_more
Programming Languagesexpand_more
Web Technologiesexpand_more
Tutorial Libraryexpand_more
Computer Science Subjectsexpand_more
GATE 2021expand_more
UGC NET / ISROexpand_more
QUIZ Sectionexpand_more
Puzzles
Geeksforgeeks Initiativesexpand_more
Contact Us
Address:
GeeksforGeeks
5th & 6th Floor, Royal Kapsons, A- 118,
Sector- 136, Noida, Uttar Pradesh (201305)
For feedback and queries: feedback@geeksforgeeks.org
For course related queries: geeks.classes@geeksforgeeks.org
For payment related issues: geeks.classes@geeksforgeeks.org
For any issue in a purchased course : complaints@geeksforgeeks.org
To contribute, please see the contribute
page`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}