$re = '/(?:^|(?<![a-z]))[a-z]\d/m';
$str = 'f9x0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);