re = /(?<=amod\().+?(?=-)/m
str = 'root(ROOT-0, love-2) s1\', \'amod(perve-5, good-4) s2
advmod(love-2, thanks-12) s3\', \'amod(mags-16, glossy-15) s4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end