$re = '/(youtube.com|youtu.be)\/(watch)?(\?v=)?(\S[^&]+)?/';
$str = 'https://www.youtube.com/watch?v=MRl7cxSOXdU&feature=youtu.be';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);