$re = '/^\/Report\/Download\/\?[^\?]*ReportName.*
/';
$str = '/Report/Download/?ReportName=Attachments
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);