# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"K'(?|(?P<name1>81)\d+|(61)\d+|(64)\d+|(1)\d+|(44)\d+|(86)\d+|(678)\d+|(41)\d+|(49)\d+|(33)\d+|(685)\d+|(\d{1,3})\d+)"
test_str = ("K'8134567\n"
"K'81345678\n"
"K'6134516789\n"
"K'61345678\n"
"K'643456\n"
"K'646345678\n"
"K'1234567890\n"
"K'12345678901\n"
"K'1454567890 <<<--- want 145 returned and not 1 \n"
"K'13345678901 <<<--- want 133 returned and not 1 \n"
"K'3214567890123\n"
"K'32134567890123\n"
"K'3654567890123\n"
"K'8934567890123\n"
"K'6554567890123\n\n\n"
"I am interested in the digits after K'\n"
"I am looking to do this using regex but not sure if it can be done. What I want is:\n"
"if the number starts with 81 return 81 \n"
"if the number starts with 61 return 61 \n"
"...\n"
"if the number starts with something i am not interested in return other(or its first digits of 1-3)\n\n"
"The above criteria works:\n\n"
"but what I also want is:\n"
"if the fist digit is 1 then return 1 BUT \n"
"if the fist digit is 1 and the 2nd and 3rd digit are 45 return 145 and don't return just 1 \n"
"if the fist digit is 1 and the 2nd and 3rd digit are 33 return 133 and don't return just 1\n\n"
"I presume I have to put something inside this part of the regex |(1)\\d+|\n\n"
"Questions:\n"
"Does regex sort the data first?\n"
"Is the order of the regex search important to how it is implemented? i deally I do not want this. \n\n\n\n\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.