re = /^abc\s+xyx\s+\d{2}\s+\d{2}\s+[a-z]\s+[a-z]\s+[a-z]/
str = 'abc xyx 12 13 a a b '
# Print the match result
str.match(re) do |match|
puts match.to_s
end