re = /^(?=.*(?>Maces|Armour|Evasion|Shields))(?!.*(?>Swords|Axes|Staves)).+$/
str = '12% Increased Physical Damage with Maces
8% Increased Armour'
# Print the match result
str.match(re) do |match|
puts match.to_s
end