$re = '/(?<=__).+/';
$str = 'ABCD__A123';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);