import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{10,15}$)(?=.*(?:.*\\d){10}.*$)([\\(\\)\\p{Zs}.-]*[0-9]{3}[\\(\\)\\p{Zs}.-]*[0-9]{3}[\\(\\)\\p{Zs}.-]*[0-9]{4})$";
final String string = "(501) 555 1234\n"
+ "(501)-555.1234\n"
+ "501-555-1234\n"
+ "501.555.1234\n"
+ "501 555 1234\n"
+ "501) 343-2233\n"
+ "(501 343-2233\n"
+ "(501. 343-2233\n"
+ "5013432233\n"
+ "800-..555-1234\n"
+ "(.8005551234\n\n\n"
+ "*-(.8005551234\n"
+ "501*555-1234\n"
+ "-(.80055512 41\n"
+ "501_555_1234\n"
+ "555-1234\n"
+ "800-...........555-1234\n"
+ "013432233\n\n"
+ " 1. The string must be 10-15 total characters in length.\n"
+ " 2. Must contain exactly 10 digits within string.\n"
+ " 3. Can contain \"(\", \")\" , \" \", \".\", or \"-\" delimiters within the string.\n"
+ " 4. It doesn't matter how many delimiters are grouped as long as numbers are grouped in {3}{3}{4}.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}