import Foundation
let pattern = #"^(?:[1-7](?:\.[0-9]{1,2})?|8(?:\.[0-4][0-9]?|\.50?)?|0\.0[1-9]|0\.[1-9][0-9]?)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
0.00
0
00
0.1
0.79
1
1.9
2
7.64
2
3
4
5
6
7
8
1.1
2.1
3.9
4.5
5.3
6.2
7.4
8.4
8.1
8.0
8.1
8.0
8.01
8.09
8.49
8.9
8.5
8.6
0.01
0.02
0.10
0.10
0.19
0.90
1.00
1.11
4.00
7.99
8.00
8.01
8.49
8.50
8.51
8.60
9.00
9.01
10
10.00
10.01
100.99
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)