# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+),\1/\1/;t' <<< "s(469,469\"Ahn'Kahar Blood Hunter'sBattlegear(Lookalike)\",50413,49952,50071,50000},nil)
s(470,470\"Ahn'Kahar Blood Hunter's Battlegear (Lookalike)\",{51877,51911,51853,51914},nil)
s(471,471\"Ahn'Kahar Blood Hunter's Battlegear (Lookalike)\",{51002,51566,51325,50789},nil)
"