import Foundation
let pattern = #"([0-2][0-9]|[3][0|1])[.]([0][1-9]|[1][1|2])[.]([0-9]{4})[T]([0|1][0-9]|[2][0-3])([:][0-5][0-9]){2}[.][0-9]{2}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
12.05.1991T03:02:00.88
38.05.1991T03:02:00.88
29.12.0806T00:00:00.00
30.32.1991T12:00:00.13
29.12.0806T24:00:00.00
29.12.0806T10:60:00.00
01.02.1970T14:11:32.14
31.12.0000T00:59:59.99
32.02.1970T14:11:32.14
22.13.1970T14:11:32.14
22.11.1970T24:11:32.14
22.11.1970T23:60:32.14
22.11.1970T23:30:62.14
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
    var groups: [String] = []
    for rangeIndex in 1 ..< match.numberOfRanges {
        let nsRange = match.range(at: rangeIndex)
        guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
        let string = (testString as NSString).substring(with: nsRange)
        groups.append(string)
    }
    if !groups.isEmpty {
        result.append(groups)
    }
}
print(result)