package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\"hostname\"\=\"(?<device_name>[^\"]*)\"`)
var str = `"hostname"="iPhone"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}