re = /^\/A(.*)\/D$/m
str = '/A
/A/B
/A/B/C
/A/D
/A/D/E
/A/D/E/F
/A/D/E/F/H
/A/D/E/G
/A/D/E/G/I
/A/D/E/F/J
/A/D/E/G/D'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end