re = /^..(.{7}$|.[3Gw!^)]|$)|G.?.?\)/m
str = 'PPCG
^P
^[P^]P
[^?][PG]$
(?<!\\\\..)(?!]).$
^[\\w^]*$|!|]P|G]\\$$
!|[^?]P(CG|G..)?$
[^])]\\$|^\\^?P|P.\\].$
([.$?]|G\\])\\$$|^\\^?P|\\]P$
([P.$?]\\$|[]^]P|G\\]\\$|CG)$
!|((G.|P|\\.)\\$|[^?]P|CG)$
^[(!P]|G..$|]..\\||[^?]P$
^.{3,23}[.-~]..\\$$|[^P?][PG]$
^..(.[!G)(3w^]|.{7}$|$)|\\$\\?
\\.\\)|P[.$?]|w\\^|^[^|C\\\\]*$|^P
^..(.[!)3G^w]|$)|\\^.{7}$|G\\)
[PPCG]
^[P\\^]
[^\\]]$
^\\^?P
[^?][PG]$|<|PG
^[^\\\\|]*(\\\\\\\\)+[^\\\\|]*[^\\]]$
^(.{,4}|.{9}|.{16,19}|.{5}P)$
^[^?]*[PG]$|[?$].*\\$$
^[^[]P|]P|(G]|[.])\\$$
\\..$|!|\\|G|^[\\^P]P|P\\^|G.\\$$
...\\^.P|^!|G]\\$$|w|<!|^\\^?P
([^\\\\}<]{3}|][^]]|^).?[$PG]$
^(..[^^].{4,22}\\$|[^?]+\\w)$|2
^(..[^^].{4,22}\\$|[^?]+\\w)$|~
^..(.[!()3G^w]|.{7}$|$)|G\\\\
[[?C(].[-!)|w]|^P|^[^C|\\\\]*$
[?[CP(].[-<)|w]|^P|^[^C|\\\\]*$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end