package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\/?(?:\w+\/)*(\.\w+)`)
var str = `/long/path/here/.dotfile`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}