// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\/config\/(?'asset'\w+)\/sim_mgmt\/v1\/(?'rsc'profile|link){1}(\?_=\d+)?$").unwrap();
let string = "/config/dts_test/sim_mgmt/v1/profile
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}