re = /^(?=(^[03]))(?!.*(\d)\2{3})(?!^(?:0(?=1|$))?(?:1(?=2|$))?(?:2(?=3|$))?(?:3(?=4|$))?(?:4(?=5|$))?(?:5(?=6|$))?(?:6(?=7|$))?(?:7(?=8|$))?(?:8(?=9|$))?9?$)\d{7,11}$/m
str = '0123456789
01234567
011111111
3333333333
0000000000
04236587
022682673'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end