#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "-?(?<![\d.,])\d{1,3}(?:[,.]\d{3})*[.,]\d{2}(?![\d.])"
Local $sString = "'2', // no match" & @CRLF & _
"'29.2', // no match" & @CRLF & _
"'2.48'," & @CRLF & _
"'8.06.16', // no match" & @CRLF & _
"'-2.41'," & @CRLF & _
"'-.54', // no match" & @CRLF & _
"'4.492', // no match" & @CRLF & _
"'4.194,32'," & @CRLF & _
"'39,299.39'," & @CRLF & _
"'329.382,39'," & @CRLF & _
"'-188.392,49'," & @CRLF & _
"'293.392,193', // no match" & @CRLF & _
"'-.492.183,33', // no match" & @CRLF & _
"'3.492.249,11'," & @CRLF & _
"'29.439.834,13'," & @CRLF & _
"'-392.492.492,43'" & @CRLF & _
"8.06.16"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")