import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/(.+?\\.)?example\\.com(\\/[A-Za-z0-9\\-\\._~:\\/\\?#\\[\\]@!$&'\\(\\)\\*\\+,;\\=]*)?)";
final String string = "http://api.example.com/...\n"
+ "http://preview.example.com/...\n"
+ "http://www.example.com/...\n"
+ "http://purhcase.example.com/...\n"
+ "https://secure.example.com/...\n"
+ "http://example.com/...\n"
+ "http://example.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}