package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(ab|bs)(?<a>[\w]*)`)
var str = `abeeee bseeee`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}