package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{{(?:[\s]+)?(.*)([\s]+)?}}`)
var str = ` {{SOME_STRING}}
{{ SOME_STRING}}
{{ SOME_STRING }}
{{ SOME-STRING }}
{{ SomE STRING }}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}