$re = '/(\d{1,2}[/. ](?:\d{1,2}|January|Jan)[/. ]\d{2}(?:\d{2})?)/m';
$str = 'dasndljaksdhfinwejfiv 12/05/2018\'\', \'akdhaouiyfbh adv12.03.2019\',\'faytdvi advonalsdnfoaidv 5/9/2019IUAYFNVVKNVAIUEHF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);