re = /(?<!\d)(\d{1,2}[\/. ](?:\d{1,2}|(?:J(?:an(?:uary)?|u(?:ne?|ly?))|Feb(?:ruary)?|Ma(?:r(?:ch)?|y)|A(?:pr(?:il)?|ug(?:ust)?)|Sep(?:t(?:ember)?)?|(?:Nov|Dec)(?:ember)?|Oct(?:ober)?))[\/. ]\d{2}(?:\d{2})?)(?!\d)/m
str = 'dasndljaksdhfinwejfiv 12/05/2018\'\', \'akdhaouiyfbh adv12.03.2019\',\'faytdvi advonalsdnfoaidv 5/9/2019IUAYFNVVKNVAIUEHF'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end