#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^\d+.*\R)?(?:4-Diepi|5-Mts|.*\b(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\d{4}\b.*)$(*SKIP)(*F)|^\d+.*\R(\d+.*)$"
Local $sString = "Peie" & @CRLF & _
"71,176,953" & @CRLF & _
"T-re" & @CRLF & _
"71,173,557" & @CRLF & _
"5-Mts" & @CRLF & _
"41,653,495" & @CRLF & _
"45678" & @CRLF & _
"Sia" & @CRLF & _
"36,136,829" & @CRLF & _
"36,100,829" & @CRLF & _
"4-Diepi" & @CRLF & _
"120,829" & @CRLF & _
"uteCra" & @CRLF & _
"36,100" & @CRLF & _
"Oct2018"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")