import re
regex = re.compile(r"([^ ]*) ")
test_str = "79.133.215.123 - - [14/Jun/2014:10:30:13 -0400] \"GET /home HTTP/1.1\" 200 1671 \"-\" \"Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36\""
subst = " "
result = regex.sub(subst, test_str, count=1)
if result:
print(result)