$re = '/(?<=[a-z])\'(?=[a-z])/im';
$str = 'N\'Guyen';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;