$re = '/^(\d+,+)*\d+$/m';
$str = '10
10,20
10,20,
10,20,30
10,,,,,,,20
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);