$re = '/(?<=\[)|(?=\])/';
$str = '$data[ContactInfos][ContactInfo][Addresses]
';
$subst = "'";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;