package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\"POST .*)(wp-login.php)([^\"]*\"\s)(\b40[6|3|4]\b)`)
var str = `74.206.226.132 - - [25/Aug/2015:12:22:53 -0700] "POST //wp-login.php HTTP/1.0" 406 323 "-" "-"
74.206.226.132 - - [25/Aug/2015:12:22:53 -0700] "POST //wp-login.php HTTP/1.0" 406 323 "-" "-"
74.206.226.132 - - [25/Aug/2015:12:22:53 -0700] "POST //wp-login.php HTTP/1.0" 406 323 "-" "-"
74.206.226.132 - - [25/Aug/2015:12:22:53 -0700] "POST //wp-login.php HTTP/1.0" 406 323 "-" "-"
74.206.226.132 - - [25/Aug/2015:12:22:54 -0700] "POST //wp-login.php HTTP/1.0" 406 323 "-" "-"
74.206.226.132 - - [25/Aug/2015:12:22:54 -0700] "POST //wp-login.php HTTP/1.0" 406 323 "-" "-"
74.206.226.132 - - [25/Aug/2015:12:22:54 -0700] "POST //wp-login.php HTTP/1.0" 406 323 "-" "-"
74.206.226.132 - - [25/Aug/2015:12:22:54 -0700] "POST //wp-login.php HTTP/1.0" 406 323 "-" "-"
74.206.226.132 - - [25/Aug/2015:12:22:54 -0700] "POST //wp-login.php HTTP/1.0" 406 323 "-" "-"
74.206.226.132 - - [25/Aug/2015:12:22:54 -0700] "POST //wp-login.php HTTP/1.0" 406 323 "-" "-"
74.206.226.132 - - [25/Aug/2015:12:22:54 -0700] "POST //wp-login.php HTTP/1.0" 406 323 "-" "-"
74.206.226.132 - - [25/Aug/2015:12:22:54 -0700] "POST //wp-login.php HTTP/1.0" 406 323 "-" "-"
74.206.226.132 - - [25/Aug/2015:12:22:54 -0700] "POST //wp-login.php HTTP/1.0" 406 323 "-" "-"
74.206.226.132 - - [25/Aug/2015:12:22:54 -0700] "POST //wp-login.php HTTP/1.0" 406 323 "-" "-"
74.206.226.132 - - [25/Aug/2015:12:22:54 -0700] "POST //wp-login.php HTTP/1.0" 406 323 "-" "-"
74.206.226.132 - - [25/Aug/2015:12:22:54 -0700] "POST //wp-login.php HTTP/1.0" 406 323 "-" "-"
74.206.226.132 - - [25/Aug/2015:12:22:54 -0700] "POST //wp-login.php HTTP/1.0" 406 323 "-" "-"
74.206.226.132 - - [25/Aug/2015:12:22:54 -0700] "POST //wp-login.php HTTP/1.0" 406 323 "-" "-"
74.206.226.132 - - [25/Aug/2015:12:22:54 -0700] "POST //wp-login.php HTTP/1.0" 406 323 "-" "-"
108.4.106.36 - - [25/Aug/2015:12:23:19 -0700] "GET /wp-content/uploads/2015/06/picture.jpg HTTP/1.1" 200 4042 "https://www.google.com/" "Mozilla/5.0 (iPad; CPU OS 8_4 like Mac OS X) AppleWebKit/600.1.4 (KHTML, like Gecko) Version/8.0 Mobile/12H143 Safari/600.1.4"
198.46.86.215 - - [25/Aug/2015:12:23:56 -0700] "POST /wp-cron.php?doing_wp_cron=1440530636.3141849040985107421875 HTTP/1.0" 200 - "-" "WordPress/4.2.3; http://www.somewebsite.com"
50.200.239.110 - - [25/Aug/2015:12:23:55 -0700] "GET /section/somepage/ HTTP/1.1" 200 5797 "https://www.google.com" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:40.0) Gecko/20100101 Firefox/40.0"
50.200.239.110 - - [25/Aug/2015:12:23:58 -0700] "GET /wp-content/themes/somewebsite/style.css HTTP/1.1" 200 54916 "http://www.somewebsite.com/section/somepage/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:40.0) Gecko/20100101 Firefox/40.0"
50.200.239.110 - - [25/Aug/2015:12:23:58 -0700] "GET /wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.2.2 HTTP/1.1" 200 1103 "http://www.somewebsite.com/section/somepage/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:40.0) Gecko/20100101 Firefox/40.0"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}