$re = '/\bGOD\b/';
$str = 'bla bla bla bla bla bla GOD';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);