import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*(\\b(pre1|pre2)?WORD(suf1|suf2)?\\b).*)";
final String string = "1. Xxx xxx WORDsuf1 xxx xxx xxx.\n"
+ "2. Xxx xxx WORDsuf2 xxx xxx xxx.\n"
+ "3. Xxx xxx pre1WORDsuf1 xxx xxx xxx.\n"
+ "4. Xxx xxx WORD xxx xxx xxx.\n"
+ "5. Xxx xxx pre1WORD xxx xxx xxx.\n"
+ "6. Xxx xxx pre2WORDxxx xxx xxx xxx.\n"
+ "7. Xxx xxx xxxWORDxxx xxx xxx xxx.\n"
+ "8. Xxx xxx pre1WORDxxxsuf1 xxx xxx xxx.\n"
+ "9. Xxx xxx pre1xxxWORDsuf1 xxx xxx xxx.\n"
+ "10. Xxx xxx xxxWORDxxx xxx xxx xxx.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}