re = /\b(?:0?[1-9]|1[0-2])\/(?:0?[1-9]|[12]\d|3[01])\/(?:19|20)?\d{2}\b/m
str = '\'EWZ US 05/29/20 C31\',\'HSI US 12/30/20 C24900\', \'SKG1C 24\', \'S H1P 49\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end