re = /[,\s]+|[,\s]+/
str = '172.30.10.10 10 (acceptable)
172.30.10.1010 (not acceptable)
10 10 (not acceptable)
10 172.30.10.10 (not acceptable)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end