const regex = /\b(?<=class=\")[^"]+(?=\")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?<=class=\\")[^"]+(?=\\")', 'gm')
const str = `<div class="hero-slider_control-wrap bot-element">
<div class="hero-slider_control hero-slider-button-next">
<span>
Next
<i class="fal fa-angle-right"></i>
</span>
</div>
<div class="hero-slider_control hero-slider-button-prev">
<span>
<i class="fal fa-angle-left"></i>
Prev
</span>
</div>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}