re = /\bwith\s+([^,.]*)/m
str = 'This is a test with a string with punctuation, and an end. Then test words, and more text. And here whith more text with more punctuation, like that.
It should also work with a sentense finishing by a dot.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end