# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bwith\s+([^,.!?:;]*)"
test_str = ("This is a test with a string with punctuation, and an end. Then test words, and more text. And here whith more text with more punctuation, like that.\n\n"
"It should also work with a sentence finishing by a dot.\n\n"
"And what do we do with fruits? such as apples, pears and lemons?\n\n"
"Please come with this stuff:\n"
"- your laptop.\n"
"- a block of paper.\n"
"- a pencil.\n\n"
"I would not recommend sun bathing with just some oil!")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.