import Foundation
let pattern = #"^[0-9a-fA-F]{24}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"5395d1546c958bfe237af64c"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}