$re = '/Title: ((?:(?!<br>).)+)/';
$str = '{"Timestamp": "Tue Apr 07 00:32:29 EDT 2015",Title: Indian Herald: India\'s Latest News, Business, Sport, Weather, Travel, Technology, Entertainment, Politics, Finance <br><br>Product: Gecko<br>CPUs: 8<br>Language: en-GB"}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);