$re = '/^ServerIP.*[0-9]$/m';
$str = 'ServerIPfoobar0
ServerIPjhfkjfs9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);