$re = '/(https?):\/\/((www\.)?example\.com)\/([a-z0-9]{12})\/([\w\-.]+)(\.html?)?/m';
$str = 'https://example.com/4scdhh0gifzd/my-file.txt.html
https://example.com/4scdhh0gifzd/my-file.txt.htm
https://example.com/4scdhh0gifzd/my-file.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);