// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(https?)://((www\.)?example\.com)/([a-z0-9]{12})/([\w-]+\.?[\w.-]*?)(?:\.html?$|$)").unwrap();
let string = "https://example.com/4scdhh0gifzd/my-file.txt.html
https://example.com/4scdhh0gifzd/my-file.txt.htm
https://example.com/4scdhh0gifzd/my-file.txt
https://example.com/4scdhh0gifzd/my-file.txt.html
Нужно получить my-file.txt вместо my-file.txt.html
https://example.com/4scdhh0gifzd/my-file.txt.html.html
Нужно получить my-file.txt.html вместо my-file.txt.html.html
https://example.com/4scdhh0gifzd/my-file.html
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}