using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=than\s)better(?=\sabsolutely)";
string input = @"Imperfection is beauty, madness is genius and it’s than better to be absolutely ridiculous than better absolutely boring";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}