$re = '/(.*?\n){6}/m';
$str = 'a
b
c
d
e
f
g
h
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);