import re
regex = re.compile(r"""
^(a(?1)b|)$
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("\n"
"aaaabbbb\n"
"ab\n\n"
"aaabb\n"
"bbbaa\n"
"abab\n"
"abba\n"
"aabbb\n"
"bbb\n"
"aaa\n"
"aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaabbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")